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Übung A: Erstellen eines Leiterplattenprojektes 
 
Das Programmsystem Altium Designer dient zum Zeichnen von Schaltplänen und zum Leiterplatten-
entwurf. Es beinhaltet unter einer einheitlichen Oberfläche die benötigten Softwarewerkzeuge für: 

1. Zeichnen von Schaltplänen, 
2. Layoutentwurf (Leiterplattenentwurf), 
3. Entwurf von Symbolen für Schaltpläne, 
4. Entwurf von Footprints. 

Anhand einer einfachen Schaltung soll der Designflow beim Leiterplattenentwurf von der Aufnahme 
eines Schaltplans (engl. Schematic) bis zur Umsetzung in ein Leiterplattenlayout gezeigt werden.  
 

Zielstellung 
Zu der nebenstehend abgebildeten Gene-
ratorschaltung soll ein Layout für eine 
zweiseitig durchkontaktierte Leiterplatte 
mit den Abmessungen 40 mm x 20 mm 
erstellt werden. Es kommen SMD-Bau-
elemente zum Einsatz. 
 
In diesem Übungsteil wird davon ausge-
gangen, dass sich alle Bauelementesym-
bole in bereits vorgefertigten Bibliotheken 
befinden. 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Programmübersicht
Das Programmfenster unterteilt sich in 
den Arbeitsbereich A, die Navigationsleis-
te B und die Werkzeugleiste C. 
Die Navigationsleiste B gestattet es, Da-
teien bzw. Objekte auszuwählen. Die ver-
schiedenen Ansichten werden über die 
Karteikarten (z. B. ‚Files’, ‚Projects’, 
‚Libraries’ usw.) im Fenster B unten um-
geschaltet. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

In diesem Tutorial werden folgende Dokumenttypen verwendet, die sich durch ihre Dateiendung zu-
ordnen lassen: 

Dateiname.PrjPCB – Projektdatei für das gesamte Leiterplattenprojekt, 
Dateiname.SchDoc – Schaltplandatei (Schematic), 
Dateiname.PcbDoc – Leiterplattenlayoutdatei (PCB), 
Dateiname.SchLib – Bibliotheksdatei für die Schaltsymbole im Schaltplan, 
Dateiname.PcbLib – Bibliotheksdatei für das Layout der Footprints. 

Zu Beginn sollte der Pfad auf das Arbeitsverzeichnis unter  DXP → Preferences → System → Default Locations 
vorgegeben werden (in der Übung „D:\Altium“). Alle Projektdateien sollten in diesem Verzeichnis lie-
gen. 

A B 

C 
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I. Eingabe eines Schaltplans (Schematic) 
Nach dem Start des Programms Altium Designer wird zunächst ein neues Projekt (PCB Project) und 
darin ein neuer Schaltplan (Schematic) unter einem Namen angelegt und gespeichert.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Schaltsymbole von Bauelementen sind in Bauelementebibliotheken organisiert. Um Schaltungssym-
bole platzieren zu können, muss zuerst die jeweilige Bibliothek (Library) ausgewählt werden, die das 
gewünschte Bauelement enthält. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Anschließend können aus dieser Bibliothek die Bauelemente ausgewählt und auf dem Schaltplan plat-
ziert werden. Die Taste                  (Leertaste) dreht das Symbol während des Platzierens, solange es noch 
nicht abgelegt wurde. 

 
  

Projekt eröffnen 

Neues Projekt anlegen 
File → New → Project → PCB Project 

Projekt unter [Name] speichern 
File → Save Project As … → [File Name] 
(z.B. ‚Uebung1.PrjPCB’) 

Innerhalb des Projekts 
neuen Schaltplan anlegen 
File → New → Schematic 

Schaltplan unter [Name] speichern 
File → Save As … → [File Name] 
(z.B. ‚Uebung1.SchDoc’) 

Auswahl einer Bibliothek 

rechte Maustaste über dem Projekt 
öffnet ein Kontextmenü; dort 
Add Existing to Project... 
auswählen 

Auswahl des Bibliothekspfades und der 
gewünschten Bibliothek,  
hier: ‚Uebung1.SchLib’ 
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Ein Doppelklick auf ein Bauelement öffnet einen Eigenschaftendialog. Darin kann unter ‚Designator’ der 
Bauelementebezeichner (z.B. R15, X1 usw.) und unter ‚Models’ die Bauform (‚Footprint’, z. B. bei ICs 
die Gehäusebauform SO8 oder DIL8) vorgegeben werden. 
 
Nachdem alle Bauelemente platziert sind, 
können die Schaltsymbole für Betriebs-
spannungsnetze über die gekennzeichne-
ten Buttons in der Symbolleiste erzeugt 
werden. 

Nach dem Platzieren öffnet ein Doppel-
klick auf das Symbol ein Dialogfenster in 
dem die Form (Balken, Kreis usw.) und 
der Name festgelegt werden kann. Der 
Symbolname bestimmt die Zugehörigkeit 
zu einem Netz (z. B. GND, VCC oder +5V). 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Nach dem Platzieren kann verdrahtet wer-
den. Die dafür notwendigen Leitungen er-
reicht man über den gekennzeichneten 
Button in der Werkzeugleiste. Der Ver-
drahtungsmodus wird mit der rechten 
Maustaste oder der Taste         beendet. 
Die Verdrahtung sollte auf dem Raster er-
folgen um das zuverlässige Verbinden der 
Elemente sicherzustellen. 

Der Schaltplan ist jetzt fertig und sollte ge-
speichert werden. Nun werden die logi-
schen Informationen des Schaltplans zu 
den physischen Eigenschaften der Bau-
elemente in Beziehung gesetzt, um das 
Layout zu erzeugen.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Platzieren (Place) von Bauelementen 

Gewünschtes Bauelement auswählen, Place 
Button betätigen und Bauelement mit der 
Maus platzieren, 
bei Bedarf mit ‚Space’- Taste drehen, 
Platzieren mit ‚ESC’- Taste beenden. 

Auf Bibliotheksansicht umschalten. 

Anm.: sollte die Karte fehlen, kann sie über 
das Menü mit: 
View → Workspace Panels → SCH  
→ Schematic Libraries aktiviert werden. 
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II. Layoutentwurf
Zuerst muss die Datei für das Leiterplat-
tenlayout (PCB) erzeugt werden. Das ge-
schieht am besten mit dem dafür vorge-
sehenen Assistenten. Folgende Einstel-
lungen werden eingetragen (Ungenannte 
bleiben auf Default): 

→ Metric → Custom → Rectangular, Width = 
40 mm, Height = 20 mm, Title Block: aus, 
Legend String: aus, Dimension Lines: aus 

→ 2 Signal Layers, 0 Power Planes 
→ Thruhole Vias only 
→ Surface mount components,  

Components on both sides: No 
→ Leiterzugdimensionen: Default 
→ [Finish]. 

Danach wird das Dokument gespeichert 

File → Save As.. → [Uebung1.PcbDoc]. 

Dieses Dokument wird anschließend per 
“Drag and Drop” dem Projekt zugeord-
net.

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Als nächstes wird die Footprintbibliothek 
[Uebung1.PcbLib] geladen. Die Vorgehens-
weise ist die gleiche wie bei der Symbol-
bibliothek. 
Die Footprint- Bibliothek enthält Informa-
tionen zu den Abmessungen der An-
schlussflächen (engl. Pads), zum Gehäuse 
und zur Mechanik (z. B. Befestigungsboh-
rungen oder Ausfräsungen) für das jewei-
lige Bauelement. 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
Nun kann aus der logischen Struktur des Schaltplans eine Netzliste generiert und jedem Bauelement 
das passende physische Modell (Footprint) zugeordnet werden. 
 
Man wählt dazu:  

Design → Import Changes from, Execute 
Changes, Close. 

Der Nullpunkt des Koordinatensystems 
wird durch 

Edit → Origin → Set 

in der linken unteren Ecke der Leiterplatte 
positioniert. 

 
 
 
 
 
 
 
 
 
 

Das entstehende rote Feld um die Bauelemente (Room) dient der Strukturierung großer Schaltungen 
und sollte bei einfachen Projekten gelöscht werden. 
 

rechte Maustaste über dem Projekt öffnet ein Kontextmenü; 
dort den Punkt Add Existing to Project... auswählen 

Auswahl der Footprint- Bibliothek ‚Uebung1.PcbLib’ 

Room: Anklicken, Löschen 
(Taste 'Del' bzw. 'Entf') 

Zuordnen der neu er- 
stellten Leiterplatten-
layoutdatei zum Projekt 
(Drag and Drop) 

Nach Auswahl der Registerkarte ‚Files’ 
kann dort unter ‚New from template’ 
der Assistent ‚PCB Board Wizard’ ge-
startet werden 
 
Anm.: sollte die Karte fehlen, kann sie 
über das Menü mit: 
View → Workspace Panels → Sys-
tem → Files aktiviert werden. 
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Raster (engl. Grids) dienen dem Ausrichten 
von Bauelementen. Über die Tastenkombi-
nation          +        lässt sich der Dialog zum 
Einstellen des Rasters öffnen. Hier wird ein 
geeignetes Raster eingestellt, z. B.: 

Step X auf 0,127 mm (5 Mil) und 
Step Y auf 0,127 mm (5 Mil) setzen. 

Auf diesem Raster werden die Bauele-
mente und die Leiterzüge verlegt. 

 
 
 
 
 
 
 
 
 
 
 
 

Die Footprints können nun einzeln mit der 
rechten Maustaste ausgewählt und auf der 
Leiterplatte angeordnet werden. Dabei 
lässt sich die Orientierung (Drehung) mit 
der Taste                    festlegen. Bei der Plat-
zierung sollte auf eine günstige Lage der 
Bauelemente untereinander bzw. auf eine 
günstige Position von Steckern, Anzeige- 
und Einstellbauelementen, Kühlkörpern 
usw. geachtet werden. Leiterzugslängen 
insbesondere von kritischen Signalen sind 
dabei zu minimieren. 

 
 
 
 
 
 
 
 
 
 
 
 

Im Anschluss werden die Gummibänder (engl. Airwires) geroutet, d. h. den bisher symbolischen Lei-
terzügen werden konkrete Positionen zugeordnet. Mit Durchkontaktierungen (Vias) lassen sich Leiter-
züge unterschiedlicher Ebenen miteinander verbinden. 
 
Nach Auswahl des gewünschten Layers 
(Top = Oberseite oder Bottom = Unterseite 
der Leiterplatte) erreicht man die interaktive 
Verdrahtung (Routing) über das markierte 
Symbol. 

Nach Anwahl dieses Symbols werden die 
Leiterzüge mit der Maus verlegt. Zwischen 
den Layern kann während des Routens 
über die Ziffernblock-Taste         gewechselt 
werden. Durchkontakte (Vias) werden da-
bei automatisch erstellt. Die Taste 
wechselt den Vorzugswinkel der Leitungen 
beim Routen. Der Modus wird mit        oder 
der rechten Maustaste beendet. 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
Sind alle Leitungen geroutet, wird die Leiterplattenlayoutdatei gespeichert. Danach kann die Verdrah-
tung mit dem Punkt Tools → Design Rule Check... überprüft werden. Treten hierbei keine Fehler auf, kann 
jetzt die Dokumentation der Ergebnisse erfolgen: 

▪ Erstellen eines Unterlagensatzes: Schaltplan, Bestückungsplan, Layouts der Einzelebenen, 
▪ Erstellen der Gerber- Files und evtl. weiterer Unterlagen für die Leiterplattenproduktion, 
▪ Stücklisten, Einkaufslisten. 
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Übung B: Erstellen eines eigenen Bauelementes 
Viele Bauelemente sind keine Standardbauelemente. Die Footprints und Schaltsymbole müssen dann 
selbst erstellt werden. Als Beispiel soll in dieser Übung der Footprint und das Schaltungssymbol eines 
Mikrocontrollers vom Typ STM32G491KCU6 [1] der Firma STMicroelectronics in der Gehäusebauform 
UFQFPN32 erstellt werden. 
Da die Zuordnung der Anschlüsse (engl. Pins) des Schaltsymbols zu den Anschlussflächen (Pads) des 
Footprints über die Pinnummer geschieht, sollte sorgfältig auf die richtige Nummerierung geachtet 
werden. 
 

I. Erstellen eines Footprints 
Der Footprint stellt die Gesamtheit der Informationen zu den Abmessungen und der Anordnung der 
Pads, Freiflächen, Bohrungen etc. dar, die benötigt werden, um das Bauelement im Leiterplattenlay-
outprogramm routen zu können. 

Eine Auswahl von Footprints befindet sich 
im Lieferumfang des Programms und steht 
nach Einbinden der Bibliotheken zur Verfü-
gung. Hier soll jedoch davon ausgegangen 
werden, dass ein neuer Footprint für die 
Gehäusebauform UFQFPN32 erzeugt wer-
den muss. 
Grundlage sind die Layoutempfehlungen 
der Hersteller für die Größe und Lage der 
Pads, die meistens im Datenblatt des Bau-
elements zur Verfügung gestellt werden. 
Die Layoutempfehlungen können von der 
angestrebten Bestückungstechnologie ab-
hängen. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Zunächst wird eine neue Footprintbibliothek erstellt. Darin wird dann der neue Footprint angelegt. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Footprint 
UFQFPN32 

 mm 

A 0,3 

B 0,6 

C 0,5 

D 4,7 

 

Footprint zum Gehäuse UFQFPN32 (4 x 8 Anschlüsse) [1] 

Neuen Footprint erstellen 

Erstellen einer neuen Footprintbibliothek 
File → New → Library → PCB Library 
Bibliothek benennen und speichern 
File → Save As... → [Bibliotheksname] 
hier z.B. ‚Uebung2.PcbLib’... 

Danach starten des Komponenten- As-
sistenten durch: 

Tools → Component Wizard, Next, 
Auswahl folgender Einstellungen: 
QUAD und Metric (mm) → 
Pad- Abmessungen laut Datenblatt: 
Breite (B) = 0.6 mm,  
Höhe (A) = 0.3 mm → 
Padform – default → 
Begrenzungslinie – default → 
Pad- Abstände laut Datenblatt jeweils: 
Pad zu Pad (C) = 0.5 mm, 
Pad zu Rand = 0.6 mm, → 
Zählrichtung - default → 
Pin-Anzahl: X = 8, Y = 8 → 
Name: UFQFPN32 → [Finish], 

abspeichern: File → Save 
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II. Erstellen eines Schaltsymbols 
Danach wird das neue Schaltsymbol für den Mikrocontroller erstellt. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Erstellen einer neuen Bauelementebibliothek 
File → New → Library → Schematic Library 
Bibliothek benennen und speichern 
File → Save As... → [Bibliotheksname] 
hier z.B. ‚Uebung2.SchLib’, 

Auf Bibliotheksansicht um-
schalten und... 

Informationen für das Bauelement ein-
tragen, z.B.: Default Designator: D?, 
Symbol Reference: STM32G491KCU6 

Auswahl der  
Footprint-Bibliothek, hier  
’Uebung2.PcbLib’ und  
des zuvor erstellten Foot-
prints ‚UFQFPN32’ 
 

danach alle Dialoge 
mit OK verlassen. 

Schaltsymbol erzeugen, Daten eintragen 

Hinzufügen eines 
Footprint-Modells, 
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Nachdem das Bauelement angelegt ist, und die Daten eingetragen wurden, kann das Symbol gezeich-
net werden. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Hinweis: Die Zuordnung zwischen Layout-Pad und Anschluss des Symbols erfolgt durch Zuweisen des 
gleichen Bezeichners (Nummer im Feld ‚Designator‘).  
 
So erstellte Bauelemente lassen sich nun in anderen Projekten nutzen, nachdem die beiden Bibliothe-
ken, wie in Übung 1 beschrieben, zum Projekt hinzugefügt werden. 

Schaltsymbol zeichnen 

Ein Doppelklick auf das Pin öffnet 
den Eigenschaftendialog: 

Hier wird der Name, die Ausrich-
tung und das elektrische Verhalten 
der Pins (Ein- / Ausgang, Versor-
gungsspannung) anhand des Da-
tenblatts eingestellt. 

Bsp.: ‚VDD’; Pin 1; power 
         ‚PA0’; Pin 5; I/O 
 

Logisches Anordnen der Pins lt. 
Datenblatt, Abspeichern! 

Rechteckigen 
Symbolumriss 
zeichnen... 

...und Pins platzieren, dabei bei 
Bedarf mit der ‚Space’- Taste dre-
hen. Das Fadenkreuz markiert den 
elektrischen Anschluss. 
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Quellen 
[1]  Datenblatt für Mikrocontroller STM32G491KCU6 

https://www.st.com/resource/en/datasheet/stm32g491kc.pdf (8.4.2026) 
 
 

Glossar 
Airwires   … Symbolische Darstellung der Verbindungen (Gummibänder) 
Bottom    … Unterseite der Leiterplatte 
Button    ... Grafisches Symbol, Schaltfläche im Programm 
Component   ... Bauteil 
default (Einstellung)  ... Standardeinstellung – „auf Voreinstellung lassen“ 
Drag and Drop   … In grafischen Benutzeroberflächen: Ziehen einer Datei zu 

einem Ziel mit der Maus 
Designflow   ... Schrittfolge bei Projektbearbeitung in einem Entwurfssystem 
Footprint   ... „Fußabdruck“ des Bauelements auf der Leiterplatte - 
     Gesamtheit der Pads, Bestückungsaufdrucke usw. 
Grid    ... Raster 
Layer    ... Zeichnungsebene, z. B. Mechanik-Layer oder Top-Layer 
Library    ... Bibliothek 
Mil    … im Layoutentwurf übliche Längeneinheit: 

1 Mil = 1/1000 Inch, d. h. 0,0254 mm 
Pad    ... Anschlussfläche eines Bauelements auf der Leiterplatte 
PCB    ... „Printed Circuit Board“ – Leiterplatte, Platine 
Pin    ... einzelner Anschluss eines Bauelements 
Routen    ... Verlegen von Leiterzügen 
Schematic   ... Schaltplan, Stromlaufplan 
SMD-Bauelement  ... Surface Mounted Device 
Space (Taste)   ... Leertaste 
Top    ... Oberseite der Leiterplatte; meist Bestückungsseite 
Via    ... Durchkontakt 
 

Shortcuts 

Funktion Tastenkombination 

Zoomen 'Strg' + Mausrad   oder   'Bild ' bzw. 'Bild ' 
Kopieren 'Strg' + 'C' 
Ausschneiden 'Strg' + 'X' 
Einfügen 'Strg' + 'V' 
Aktion rückgängig (Undo) 'Strg' + 'Z' 
Aktion wiederherstellen (Redo) 'Strg' + 'Y' 
Drehen eines ausgewählten Objektes 'Space' (Leertaste) 
Eigenschaftendialog zu einem Objekt 'Tab' 
  
PCB: Layerdialog 'L' 
PCB: Einheiten Mil / mm umschalten  'Q' 
PCB: Raster einstellen 'G' 
PCB: Abstand Messen 'Strg' + 'M' 
PCB: Single / Multi-Layer Mode 'Shift' + 'S' 
PCB: Layout-Ansicht / 3D-Ansicht '2' / '3' 

 

Dieses Dokument wurde zur Nutzung mit dem Programm „Altium Designer 14“ erstellt. 


